MSI Wind U100 i filmy HD

Od jakiegoś czasu posiadam MSI Wind U100. Genialny netbook ze wspaniałym ekranem i klawiaturą. Wspaniale robi on na zajęciach za notatnik etc. Recenzji w netcie tego sprzętu jest masa wiec nie będę się na ten temat rozpisywać.

Otóż dziś zasiadłem z zamiarem zmuszenia go od odpalenia filmu 720p kodowanego x264 (h264) bez przycinania się i testując na tym co mam mogę powiedzieć, że mi się udało (owy sposób powinien też działać na innych netbookach).

Użyłem do tego najlepszego odtwarzacza jaki znam czyli mplayera (LINK) czystego bez żadnej nakładki graficznej ;>. Osiągnąłem to pod Windowsem XP (pod linuxem zapewne da się bez problemu tez w dokładnie taki sam sposób).

No dobra to zaczynamy. Pierw ściągnąłem ze strony http://oss.netfarm.it/mplayer-win32.php najnowszego builda mplayera z obsługa multi thread (p4 mt). Najnowsza wersja powinna być na tej stronie pod linkiem „p4 mt”.

Dalej w configu (mplayer/config) dopisałem linijkę

lavdopts=threads=2

i to wszystko. Teraz filmy zakodowane w x264 (h264) są dekodowane przez dwa wątki i chodzą płynnie nawet bez Turbo Mode na moim „wiaterku”.

Cały mój plik konfiguracyjny wygląda tak

vo=directx
#vo=gl2
#dr=yes
double=yes
font=subfont.ttf
subcp=cp1250
subfont-text-scale=2.5
#subfont-text-scale=4
ao=dsound
autosync=100
#framedrop=yes
framedrop=no
quiet=yes
#monitoraspect=1024:600
#monitoraspect=1440:900
#liczba kanałow
channels=2
#vf=pp,eq
#mc=0.001
#dziwnie skalowal czasem wiec ta opcja pomaga
noaspect=1
#dwa watki do dekodowania h264
lavdopts=threads=2

Samego mplayera w Windowsie używam tak, że jest on domyślną aplikacja do odpalania filmów więc wystarczy kliknąć 2x na filmie i już leci.

Jeśli ktoś miałby jakieś pytania to postaram się pomóc wiec możecie śmiało pytać w komentarzach.

Dodaj komentarz

Twój adres email nie zostanie opublikowany. Pola, których wypełnienie jest wymagane, są oznaczone symbolem *